
Modbus RTU Analog Input 8CH 

Overview 

Hardware Description 

• Each channel can be individually configured for its range, making it more convenient 

for users. 

"AIN+" is the positive input, and "AIN-" is the negative input. The module supports 

both differential and single-ended input. When used as a single-ended input, "AIN-" is 

connected to the ground. 

 
Note: When inputting the different powers, it is important to connect the ground wire 

to establish a common ground. Otherwise, the collected data may be inaccurate. 

• Opening the device case, you can see jumpers are near the device terminals, 

corresponding to the eight channels AI1~AI8. You need to select the jumper mode 

based on the measurement signal; otherwise, the measurement data will be inaccurate. 
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o When measuring voltage signals, the jumper wire for the corresponding channel 

should be disconnected. 

o When measuring current signals, the jumper wire for the corresponding channel 

should be connected. 

 

• Modbus RTU Analog Input 8CH defaults to current mode with the jumper wire 

connected. Modbus RTU Analog Input 8CH (B) defaults to voltage mode with the 

jumper wire disconnected. 

Version Comparision 

• Currently, there are two versions of the analog input series, one defaults to current 

input, and the other defaults to voltage input. 
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Version Modbus RTU Analog Input 8CH Modbus RTU Analog Input 8CH (B) 

Default mode 8-ch current mode, 0~20mA 8-ch voltage mode, 0~10V 

Measurement range 0~5V/1~5V 
0~20mA/4~20mA 

0~10V/2~10V 
0~20mA/4~20mA 

Resolution 12-bit 12-bit 

Current sampling resistance 249Ω 499Ω 
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Operational amplifier ratio 32.4/49.9 10/32.4 

Channel 8-AI 8-AI 

• Each version has five range modes from 0 to 4. 

Mode Modbus RTU Analog Input 8CH Modbus RTU Analog Input 8CH (B) 

0 0~5V voltage mode 0~10V voltage mode 

1 1~5V voltage mode 2~10V voltage mode 

2 0~20mA current mode 0~20mA current mode 

3 4~20mA current mode 4~20mA current mode 

4 4096-scale code mode 4096-scale code mode 

• The scale code is the data collected by the AD converter and needs to undergo a linear 

transformation to obtain voltage or current data. The conversion formula is as follows. 

o Voltage = Scale Code * 3300/4095/Operational Amplifier Ratio 

o Current = Voltage/Sampling Resistor 

Hardware Connection 

• Connect the USB TO 485 to the target boards via cables, A-A and B-B connected as 

shown below: 



 

Software Test 

SSCOM Serial Port Debugging Assistant 

• Download SSCOM serial port debugging assistant and open it on the computer. Open 

the corresponding port number, set the baud rate as 9600, and select SendHEX and 

HEXshow. 

Send the following command, and it will return the 8-channel analog input data 

normally. 

01 04 00 00 00 08 F1 CC 

https://files.waveshare.com/wiki/common/Sscom5.13.1.zip
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• If you need to send other commands, choose SendHEX. For checksum validation, select 

ModbusCRC16. After entering the first six bytes of the command, clicking SEND will 

automatically add the CRC check code. For example, send the following command, you 

can set channel 1 to 4-20mA current input mode. 
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• For more control commands, you can refer to the development protocol. 

Modbus Poll Software 

• It is not convenient to use the SSCOM software for observing the data, you can 

select Modbus Poll software to read the data. Download and install the Modbus Poll 

software. 

• Open the software, select Setup -> Read/Write Definition. Select the actual device 

address for Slave ID, 04 Read Input Registers (3x) for Function, and 8 channels for 

Quantity, and click "OK" to confirm. 

 

• Select Connection->Connect..., choose the corresponding serial port, set the baud rate 

to 9600, and select 8 Data bits and None Parity. Click OK to connect. 
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• After successful connection, it can display the analog input data for channels 1-8. 
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• Modbus RTU Analog Input 8CH (A) displays the current by default, and the unit is uA. 

Modbus RTU Analog Input 8CH (B) displays the voltage by default, and the unit is mV. 

• Choose File->New to create a new window, select Setup->Read/Write Definition. Select 

the actual device address for Slave ID, 16 Write Multiple Registers for Function, Hex for 

Address Mode, 1000 for Address, and 8 channels for Quantity, and then click "OK" to 

confirm. 

 

• The new window 2 can set up the measuring modes for different channels. For 

example, you can set the channel 1 mode as 2, that is, 0~20mA current mode. And 

channel 1 of the window 1 will display the current. 
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Note: The internal jumper wires should be modified when changing the current and 

voltage mode, otherwise, the measurement data will not be accurate. 

 

Demo Test 
Note: RS485 can not be directly connected to the serial port of the Raspberry Pi, 

otherwise it may burn the device, you need to add 485 level conversion. For Raspberry 

Pi, it is recommended to work with the RS485 CAN HAT module. For NUCLEO-F103RB 

and Arduino, it is recommended to work with the RS485 CAN Shield module. 

Raspberry Pi 

Open the Raspberry Pi terminal and enter the following command to enter the 

configuration interface 

sudo raspi-config 

Select Interfacing Options -> Serial, disable shell access, and enable the hardw
are serial port 
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Then restart Raspberry Pi: 

sudo reboot 

Open the /boot/config.txt file, find the following configuration statement to enable 

the serial port, if not, you can add it to the end of the file. 

enable_uart=1 

For Raspberry Pi 3B users, the serial port is used for Bluetooth and needs to be 

commented out: 

#dtoverlay=pi3-miniuart-bt 

Then restart Raspberry Pi: 

sudo reboot 

Insert the RS485 CAN HAT into the Raspberry Pi, and connect the Modbus RTU Relay 

module to the RS485 CAN HAT through A and B. 

If you are using other 485 devices, make sure to connect A-A, B-B. 

Run the following commands to run the demo: 

sudo apt-get install unzip 

sudo apt-get install python3-pip 

pip install modbus_tk 

wget https://files.waveshare.com/wiki/Modbus-RTU-Analog-Input-8CH/Modbus_RTU_Ana
log_Input_Code.zip 

unzip Modbus_RTU_Analog_Input_Code.zip 
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cd Modbus_RTU_Analog_Input_Code/Python3 

sudo python3 modbus.py 

STM32 

Note: The STM32 demo is based on the NUCLEO-F103RB and RS485 CAN Shield 

module. 

1. Download Demo, find the STM32 project file Modbus.uvprojx in the path 

Modbus_RTU_Analog_Input_Code\STM32\MDK-ARM, and double-click to open the 

STM32 project file. Note that you should ensure Keil5 software is installed on your 

computer before using it. 

 
2. Connect the STM32 to a computer via the STM32 download and debug probe. 

Compile and download the program to the development board. 
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3. Install the RS485 CAN Shield module on the STM32. Connect the RS485_A on the 

RS485 CAN Shield module to the RS485_A on the Modbus RTU Analog Input 8CH via a 

wire, and connect the RS485_B on the RS485 CAN Shield module to the RS485_B on 

the Modbus RTU Analog Input 8CH via a wire. Then power on the Modbus RTU 

Analog Input 8CH and the STM32 sequentially. 

4. After the program runs normally, you can observe through the serial port assistant 

that the device prints the collected results 

 

Arduino 

Note: The Arduino demo is based on the UNO PLUS and RS485 CAN Shield module. 

1. Download Demo, find the Arduino project file Modbus_RTU_Analog_Input.ino in the 

path Modbus_RTU_Analog_Input_Code\Arduino\Modbus_RTU_Analog_Input, and 

double-click to open the Arduino project file. Note that you should ensure Arduino 

IDE software is installed on your computer before using it. 
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2. Connect the Arduino to the computer via a USB cable. In the Arduino IDE software, 

select the Arduino board model under Tools->Board. Choose the COM port that the 

Arduino is connected to under Tools->Port. 

3. After seeing the prompt to connect to the computer in the lower right corner, click 

to compile and flash the program, and wait for the flashing to complete. 

 

4. Install the RS485 CAN Shield module on the Arduino. Connect the RS485_A on the 

RS485 CAN Shield module to the RS485_A on the Modbus RTU Analog Input 8CH via a 

wire, and connect the RS485_B on the RS485 CAN Shield module to the RS485_B on 
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the Modbus RTU Analog Input 8CH via a wire. Then power on the Modbus RTU 

Analog Input 8CH and the Arduino sequentially. 

5. After the program runs normally, you can observe through the serial port assistant 

that the device prints the collected results 

 

Development Protocol V2 

Function Code Introduction 

Function Code Description 

03 Read holding register 

04 Read input register 

06 Write single holding register 

10 Write multiple holding register 
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Register Address Introduction 

Address 
(HEX) 

Address 
storage 
content 

Register value Permission Modbus 
Function Code 

3x0000 
…… 
3x0007 

Channels 1~8 
input data Read values as unsigned hexadecimal Read 0x04 

4x1000 
…… 
4x1007 

Channels 1~8 
data types 0x0000~0x0004 five ranges Read/Write 0x03,0x06,0x10 

4x2000 UART 
Parameter 

The high eight bits indicate the parity mode: 
0x00~0x02 
The low eight bits indicate the baud rate 
mode: 0x00~0x07 

Read/Write 0x03, 0x06 

4x4000 Device 
Address 

Directly store Modbus address 
Device address: 0x0001-0x00FF Read/Write 0x03, 0x06 

4x8000 Software 
Version 

Converting to decimal and then shifting the 
decimal point two places to the left will 
represent the software version 
0x0064 = 100 = V1.00 

Read 0x03 

Operation Command Introduction 

Read Analog Input Command 

Send code: 01 04 00 00 00 08 F1 CC 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

04 04 command Read input register 

00 00 Register Start 0x0000 - 0x0007 correspond to 1~8 input channels 



Address 

00 08 Register Number The number of the registers to be read, which must not exceed the maximum 
number of the channels 

F1 
CC CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 01 04 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 55 2C 

Field Description Note 

01 Device 
Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

04 04 command Read input register 

10 Byte Number Data length 

00 00 
…… 
00 00 

Register data 

Indicates the values of analog inputs from channels 0 - 7 
An unsigned 16-bit identifier for a channel, with the higher bits first and the lower 
bits last 
The data range is determined by the output data type 

55 
2C CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: [Address 1 device] 

Read 1-8 channels : 01 04 00 00 00 08 F1 CC 

Read 1 channel : 01 04 00 00 00 01 31 CA 

Read 2 channel : 01 04 00 01 00 01 60 0A 

Read 3-5 channels : 01 04 00 02 00 03 11 CB 

Read Channel Data Type Command 

Send code: 01 03 10 00 00 08 40 CC 

Field Description Note 



01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

03 03 Command Read holding register 

10 00 Register Start 
Address 0x1000 - 0x1007 correspond to 1~8 input channels 

00 08 Register Number The number of the registers to be read, which must not exceed the maximum 
number of the channels 

40 
CC CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 01 03 10 00 02 00 02 00 02 00 02 00 02 00 02 00 02 00 02 09 C3 

Field Description Note 

01 Device 
Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

03 03 Command Read holding register 

10 Byte Number The number of all bytes of the returned status information 

00 02 
…… 
00 02 

Data Type 

Indicates data types of 0-7 channels, 0x0000~0x0004 represents five ranges 
0x0000: Range 0~5V, output range 0~5000 or 0~10000, unit mV; 
0x0001: Range 1~5V, output range 1000~5000 or 2~10V, output range 
2000~10000, unit mV; 
0x0002: Range 0~20mA, output range 0~20000, unit uA; 
0x0003: Range 4~20mA, output range 4000~20000, unit uA; 
0x0004: Direct output of numerical code, output range 0~4096, requires linear 
conversion to obtain actual measured voltage and current; 

09 
C3 CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: [Address 1 device] 

Read data types for channels 1-8 : 01 03 10 00 00 08 40 CC 

Read data type for channel 1 : 01 03 10 00 00 01 80 CA 



Read data type for channel 2 : 01 03 10 01 00 01 D1 0A 

Read data type for channels 3-5 : 01 03 10 02 00 03 A0 CB 

Set Single-channel Data Type Command 

Send code: 01 06 10 00 00 03 CD 0B 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

06 06 Command Write single register 

10 00 Register Start 
Address 0x1000 - 0x1007 correspond to data types of 1~8 input channels 

00 03 Channel Data 
Type 

Channel data types, 0x0000~0x0004 represents five ranges 
0x0000: Range 0~5V, output range 0~5000 or 0~10000, unit mV; 
0x0001: Range 1~5V, output range 1000~5000 or 2~10V, output range 
2000~10000, unit mV; 
0x0002: Range 0~20mA, output range 0~20000, unit uA; 
0x0003: Range 4~20mA, output range 4000~20000, unit uA; 
0x0004: Direct output of numerical code, output range 0~4096, requires linear 
conversion to obtain actual measured voltage and current; 

CD 
0B CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 01 06 10 00 00 03 CD 0B 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device 
address 

06 06 Command Write single register 

10 00 Channel Data Type 
Address 0x1000 - 0x1007 correspond to data types of 1~8 input channels 



00 03 Channel Data Type Channel data type, 0x0000~0x0004 represents five ranges 

CD 
0B CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: [Address 1 device] 

Set data type to 0~20mA for channel 1 : 01 06 10 00 00 02 0C CB 

Read data type 4~20mA for channel 2: 01 06 10 01 00 03 9C CB 

Set Multi-channel Data Type Command 

Send code: 01 10 10 00 00 08 10 00 03 00 03 00 03 00 03 00 03 00 03 00 03 00 03 91 

2B 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

10 10 Command Write multiple registers 

10 00 Register Start 
Address 0x1000 - 0x1007 correspond to data types of 1~8 input channels 

00 08 Register Number Set register number, which must not exceed the maximum number of the 
channels 

10 Byte Number Set the number of bytes to be output 

00 03 
…… 
00 03 

Command 

Corresponding to data types of 0-7 channels, 0x0000~0x0004 represents five 
ranges 
0x0000: Range 0~5V, output range 0~5000 or 0~10000, unit mV; 
0x0001: Range 1~5V, output range 1000~5000 or 2~10V, output range 
2000~10000, unit mV; 
0x0002: Range 0~20mA, output range 0~20000, unit uA; 
0x0003: Range 4~20mA, output range 4000~20000, unit uA; 
0x0004: Direct output of numerical code, output range 0~4096, requires linear 
conversion to obtain actual measured voltage and current; 



91 
2B CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 01 10 10 00 00 08 C5 0F 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device 
address 

10 10 Command Write multiple registers 

10 00 Register Start 
Address 0x1000 - 0x1007 correspond to data types of 1~8 input channels 

00 08 Register Number Set register number, which must not exceed the maximum number of the 
channels 

C5 
0F CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: [Address 1 device] 

Read data type 4~20mA for channels 1-8: 01 10 10 00 00 08 10 00 03 00 03 00 03 0
0 03 00 03 00 03 00 03 00 03 91 2B 

Read data type 1~5V for channels 3-5 : 01 10 10 02 00 03 06 00 01 00 01 00 01 BE 
4A 

Set Baudrate Command 

Send code: 00 06 20 00 00 05 43 D8 

Field Description Note 

00 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

06 06 command Set the baud rate and device address 



20 00 Command Register 0x2000: set the baud rate; 0x4000: set the device address 

00 Parity Method 0x00: no parity, 0x01: even parity; 0x02: odd parity 

05 Baud Rate Value 

Correspondence of baud rate values 
0x00: 4800 
0x01: 9600 
0x02: 19200 
0x03: 38400 
0x04: 57600 
0x05: 115200 
0x06: 128000 
0x07: 256000 

43 D8 CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 00 06 20 00 00 05 43 D8 

Field Description Note 

00 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

06 06 command Set the baud rate and device address 

20 00 Command Register 0x2000: set the baud rate; 0x4000: set the device address 

00 Parity Method 0x00: no parity, 0x01: odd parity; 0x02: even parity 

05 Baud Rate 

Correspondence of baud rate values 
0x00: 4800 
0x01: 9600 
0x02: 19200 
0x03: 38400 
0x04: 57600 
0x05: 115200 
0x06: 128000 
0x07: 256000 

43 D8 CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: [Address 1 device] 



Set the baud rate as 4800: 00 06 20 00 00 00 83 DB 

Set the baud rate as 9600: 00 06 20 00 00 01 42 1B 

Set the baud rate as 115200: 00 06 20 00 00 05 43 D8 

Set Device Address Command 

Send code: 00 06 40 00 00 01 5C 1B 

Field Description Note 

00 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

06 06 command Set the baud rate and device address 

40 00 Command Register 0x2000: set the baud rate; 0x4000: set the device address 

00 01 Device Address Set the device address, 0x0001-0x00FF 

5C 1B CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 00 06 40 00 00 01 5C 1B 

Field Description Note 

00 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

06 06 command Set the baud rate and device address 

40 00 Command Register 0x2000: set the baud rate; 0x4000: set the device address 

00 01 Device Address Set the device address, 0x0001-0x00FF 

5C 1B CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: [Address 1 device] 

Set the device address as 0x01: 00 06 40 00 00 01 5C 1B 



Set the device address as 0x02: 00 06 40 00 00 02 1C 1A 

Set the device address as 0x03: 00 06 40 00 00 03 DD DA 

Read Device Address Command 

Send code: 00 03 40 00 00 01 90 1B 

Field Description Note 

00 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

03 03 Command Read the device address 

40 00 Command register 0x4000: read the device address, 0x8000: read software version 

00 01 Byte Number Fixed 0x0001 

90 1B CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 01 03 02 00 01 79 84 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

03 03 Command Read the software version and device address 

02 Byte Number The number of bytes returned 

00 01 Device Address Set the device address, 0x0001-0x00FF 

79 84 CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: [Address 2 device] 

Send: 00 03 40 00 00 01 90 1B 



Return : 02 03 02 00 02 7D 85     // Address 0x02 

Read Software Version Command 

Send code: 00 03 80 00 00 01 AC 1B 

Field Description Note 

00 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

03 03 Command Read the software version and device address 

80 00 Command register 0x4000: read the device address, 0x8000: read software version 

00 01 Byte Number Fixed 0x0001 

AC 1B CRC16 The CRC16 checksum of the first 6 bytes of data 

Return code: 01 03 02 00 64 B9 AF 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device address 

03 03 Command Read the software version and device address 

02 Byte Number The number of bytes returned 

00 64 Software 
Version 

Converting to decimal and then shifting the decimal point two places to the left 
will represent the software version 
0x0064 = 100 = V1.00 

B9 
AF CRC16 The CRC16 checksum of the first 6 bytes of data 

For example: 

Send: 00 03 80 00 00 01 AC 1B 



Return: 01 03 02 00 64 B9 AF       //0x0064 = 100 =V1.00 

Exception Function Code 
When the received command is incorrect or the device is abnormal, an exception 

response will be returned in the following format: 

Return: 01 85 03 02 91 

Field Description Note 

01 Device Address 0x00 indicates the broadcast address, 0x01-0xFF indicates the device 
address 

85 Exception Function 
Code Exception function code = Request function code + 0x80 

03 Byte Number Exception Code 

02 
91 CRC16 The CRC16 checksum of the first 6 bytes of data 

An exception code is a single-byte value that indicates the type of error. Several 

commonly used exception codes defined by the Modbus protocol: 

Exception 
Code Name Description 

0x01 Illegal Function The requested function code is not supported 

0x02 Illegal Data 
Address The requested data address is incorrect 

0x03 Illegal Data Value The requested data value or operation cannot be executed 

0x04 Server Failure Server equipment failure 

0x05 Response The request has been received and is being processed 



0x06 Device Busy The device is currently busy and cannot perform the requested 
operation 

Resources 

Demo 

• Demo 

Software 

• Sscom serial port debugging assistant 

• Modbus Poll software 

• SecureCRT software 

Related Resources 

• Modbus Protocol Specification 

• Modbus Series BootLoader Description 
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