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Chapter 1

Introduction
The Alveo™ programming cable provides development access for debug-port enabled Alveo data
center accelerator cards. The cable provides micro-USB support from a host PC to the
maintenance connector allowing the card to be programmed using the Vivado® hardware
manager.

The Alveo programming cable is available for purchase at Alveo Accessories and includes the
programming module, 6-inch ribbon cable, USB cable, and a special adapter that supports the
Alveo U25 SmartNIC data center accelerator cards. Debug-port enabled Alveo data center
accelerator cards have a maintenance connector that connects to the programming module
through a ribbon cable. The programming module connects to the host computer though a
micro-USB that also provides power. The following cards are debug-port enabled and support
the Alveo programming cable.

• U50

• U25

The following figure shows the Alveo programming module with available interface call-outs. The
following table describes each call-out. Chapter 3: Programming Cable Component Descriptions
gives additional information on each component.
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Figure 1: Alveo Programming Module Interface Locations

3

2

1

X23424-102319

Table 1: Alveo Programming Module Interface Descriptions

Call-out Interface Description
1 2x15-pin debug connector Provides connection between the programming module and some Alveo

data center accelerator cards. Used for programming the programmable
device.

2 Micro USB connector port 1 Provides connection between host system, with Vivado® Design Suite
installed, and the programming module. Used for programming the
Alveo data center accelerator card.

3 Unused Reserved. Unused for development tool flows.

Notes:
1. An Alveo programming cable is required for development access. The cable provides micro-USB support from a host

PC to the card maintenance connector and can be purchased from Xilinx at Alveo Accessories.
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Chapter 2

System Setup using the
Programming Cable

Standard ESD Measures
CAUTION! ESD can damage electronic components when they are improperly handled, and can result in
total or intermittent failures. Always follow ESD-prevention procedures when removing and replacing
components.

To prevent ESD damage:

• Attach a wrist strap to an unpainted metal surface of your hardware to prevent electrostatic
discharge from damaging your hardware.

• When you are using a wrist strap, follow all electrical safety procedures. A wrist strap is for
static control. It does not increase or decrease your risk of receiving electric shock when you
are using or working on electrical equipment.

• If you do not have a wrist strap, before you remove the product from ESD packaging and
installing or replacing hardware, touch an unpainted metal surface of the system for a
minimum of five seconds.

• Do not remove the device from the antistatic bag until you are ready to install the device in
the system.

• With the device still in its antistatic bag, touch it to the metal frame of the system.

• Grasp cards and boards by the edges. Avoid touching the components and gold connectors on
the adapter.

• If you need to lay the device down while it is out of the antistatic bag, lay it on the antistatic
bag. Before you pick it up again, touch the antistatic bag and the metal frame of the system at
the same time.

• Handle the devices carefully to prevent permanent damage.
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Connecting and Disconnecting the Ribbon
Cable

A 2x15 ribbon cable is required to connect between the Alveo data center accelerator card and
the programming module. See Programming Cable.

Connecting the Ribbon Cable

When connecting the ribbon cable and programming module, align the cable key with the
spacing on the maintenance connector. The cable key is shown in the following image.

Figure 2: Ribbon Cable Key

IMPORTANT! The ribbon length you use can vary depending on your system setup. For ribbon cable
lengths greater than six inches, the JTAG transfer frequency used by the Vivado® hardware manager to
program the card must be reduced from 15 MHz to 10 MHz. Complete details are discussed in Chapter 4:
Programming the Alveo Data Center Accelerator Card.

IMPORTANT! The U25 card can only be programmed using the 6-inch cable. Longer cables are not
supported.

Debug-port enabled Alveo data center accelerator cards have a maintenance connector that
attaches to the corresponding connector on the programming module through the ribbon cable.
The corresponding connector on the programming module is shown in Figure 3. Figure 4 shows
the ribbon cable attaching to the 2x15-pin maintenance connector of the Alveo U50 data center
accelerator card.
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Figure 3: Connecting Ribbon Cable to Debug Connector

Figure 4: Attaching the Ribbon Cable to Alveo Maintenance Connector Port

When attaching the cable, apply gentle pressure and ensure the cable has a tight connection.

IMPORTANT! Do not apply excessive force when connecting the ribbon cable as the connector pins can
be damaged or bent.

The Alveo U25 card requires the adapter card (shown in the following image) to convert the U25
debug edge connector to the 2x15-pin connector format. Prior to connecting the adapter to the
debug port of the U25 card, attach the six-inch ribbon cable to the adapter card.
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Figure 5: Adapter Card

With the ribbon cable attached to the adapter card, gently connect the adapter card to the U25
debug port, found at the top of the card as shown in the following figure.

Figure 6: U25 Adapter Connected to the Alveo U25 Card

IMPORTANT! Do not apply excessive force when connecting the ribbon cable as the connector pins can
be damaged or bent.

Disconnecting the Ribbon Cable

When removing the ribbon from the Alveo card, adapter card, or the programming module, firmly
hold the ribbon connector and pull the cable out in a straight line. Twisting or rotating the
connector will damage the connector pins on the Alveo data center accelerator card or the
programming module.
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Connecting the Alveo Programming Module
This section outlines the programming module connection to the Alveo data center accelerator
card procedures. Depending on your system setup, the following installation steps could differ.
The following example uses a 15-inch cable. Two adjacent PCIe® slots are necessary: one for the
Alveo data center accelerator card and the other for ribbon cable access.

IMPORTANT! The U25 card can only be programmed using the 6-inch cable. Longer cables are not
supported.

1. Before installing the Alveo data center accelerator card, connect one end of the ribbon cable
to the maintenance port on the Alveo data center accelerator card following the instructions
outlined in Connecting the Ribbon Cable.

2. Power off the server and install the Alveo data center accelerator card in the server. Follow
the card installation procedures described in the card specific installation guide (see 
References).

3. When the card is installed, guide the ribbon cable through the adjacent PCIe slot, providing
enough length to attach it to the Alveo programming module.

4. Attach the other end of the ribbon cable to the maintenance connector on the Alveo
programming module following the instructions outlined in Connecting the Ribbon Cable.
The following figures show the subsequent setup from the top and side views.
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Figure 7: Installed Alveo Data Center Accelerator Card Connected to Alveo
Programming Module – Top View
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Figure 8: Installed Alveo Data Center Accelerator Card Connected to Alveo
Programming Module – Side View

5. Replace the server cover.

6. Attach the micro-USB cable to USB port 1 of the Alveo programming module. The following
figure shows both the ribbon (on the left side) and USB connected (on the right side).
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Figure 9: Alveo Programming Module with Ribbon and USB Cables Connected

7. Guide the other end of the micro-USB cable to a location that is accessible by the host
computer/laptop with the Vivado® Design Suite installed.

The Alveo programming module is successfully installed and the server can now be powered on.
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Chapter 3

Programming Cable Component
Descriptions

This chapter provides a functional description of the components of the Alveo™ programming
cable.

Programming Module Specifications
Dimensions (Square Form Factor)

Figure 10: Programming Module Dimensions

69mm
15mm

69mm

X23509-110819
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The following dimensions are of the PCB inside the programming module:

Height: 2.5 inch (6.35 cm)
Length: 2.5 inch (6.35 cm)
Thickness (±5%): 0.062 inch (0.1574 cm)

Environmental

Operating Temperature: 0°C to +55°C
Storage Temperature: –40°C to +75°C
Humidity: 10% to 90% non-condensing

Debug Header for Connecting with the Main
Card

The programming module, populated with a 2x15-pin debug connector (shown as call-out 1 in 
Figure 1), connects to the Alveo Data Center accelerator card with a ribbon cable. The 2x15
connector details are listed.

• Manufacturer: SAMTEC

• Part number: FTSH-115-01-F-D-RA-K

• Description: CONN HEADER R/A 30POS 1.27MM

The connector debug header pin definitions are listed in Table 2: Micro-USB Connectors.

Micro USB Connectors
The programming module has two micro-USB connectors (call-outs 2 and 3 in Figure 1), one for
each FT4232 USB to multi-protocol converter. Connect the external micro-USB cable from the
host to the micro-USB connector 1 (call-out 2 in Figure 1). The micro-USB connector number 2
should be left unused (call-out 3 in Figure 1). The pin description of the micro-USB connector is
listed in the following table.
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Table 2: Micro-USB Connectors

Pin Number Signal Name Functionality
1 USB_VBUS USB power

2 USB_DN USB differential data –

3 USB_DP USB differential data +

4 USB_ID USB ID

5 GND Ground

6 GND Shield ground

7 GND

8 GND

9 GND

10 GND

11 GND

Programming Cable
The required cables for the programming module are listed in the following table.

Table 3: Maintenance Board Accessories

Item
Number

Quantity
per

Board
Description Manufacturer Manufacturer

Part Number Notes

1 1 Ribbon cables/IDC
cables .050" tiger-eye
IDC ribbon cable
assembly, 1.27 mm, 30
position, 6" length,
female to female

Samtec FFSD-15-D-06.00-01-N Connection between
programming module
and Alveo data center
accelerator card
connector.

2 1 Cable USB-A TO micro
USB-B 2M

Assmann AK67421-2-R Connection between
programming module
and external device (i.e.,
host computer)
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Chapter 4

Programming the Alveo Data
Center Accelerator Card

When using the Vitis™ IDE flow, follow the software and platform installation instructions in the
specific card installation guide (see References). Traditional RTL-flow Alveo data center
accelerator cards, enabled with a maintenance port, can be programmed using the Alveo
programming module and the Vivado® Design Suite hardware manager application. To use this
flow:

• Vivado® Design Suite 2019.1 or later hardware manager must be installed on your host
machine or laptop to program the device via JTAG.

• Alveo data center accelerator card must be installed (see Connecting the Alveo Programming
Module) and the server powered on.

• Alveo programming cable connected as described in Connecting the Alveo Programming
Module.

Steps to Connect and Program the Alveo Data
Center Accelerator Card

To connect and program the Alveo data center accelerator card using the Vivado Design Suite
hardware manager:

1. Attach the free end of the USB cable (coming from the Alveo programming module) to the
host computer to connect the module with the host computer.

2. Start the Vivado Design Suite on the host computer.

3. Open the hardware manager by selecting Flow Navigator → Open Hardware Manager.

4. Select Tools → Auto Connect to open the target. A window, similar to one shown in the
following example opens. In this case, an Alveo U50 is connected.
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Figure 11: Vivado Design Suite Hardware Manager Auto-Connect

When using a ribbon cable longer than 6 inches, the JTAG transfer frequency must be
changed from 15 MHz to 10 MHz. This lower frequency ensures proper signal integrity and
successful programming. To change the JTAG transfer frequency to 10 MHz, run the
following Tcl command in the hardware manager command line as shown in the following
image:

set_property PARAM.FREQUENCY 1000000 [current_hw_target]

Figure 12: Changing JTAG Transfer Frequency via Tcl Command

5. Choose the memory configuration device on the card.

a. Right-click on the target opened and select Add Configuration Memory Device.

b. Select the memory associated with the card installed, and click OK.

c. When prompted to program the configuration memory device, click OK.

6. Select the desired MCS file.

7. In the Address Range drop-down list, select Configuration File Only and click OK.

8. Disconnect the card in the Vivado Design Suite hardware manager.

9. Disconnect the USB cable from your host computer.

10. Power-cycle the card. The card is now updated.
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Appendix A

Regulatory and Compliance
Information

This product is designed and tested to conform to the European Union directives and standards
described in this section.

For Technical Support, open a Support Service Request.

CE Information
CE Directives

2006/95/EC, Low Voltage Directive (LVD)

2004/108/EC, Electromagnetic Compatibility (EMC) Directive

CE Standards

EN standards are maintained by the European Committee for Electrotechnical Standardization
(CENELEC). IEC standards are maintained by the International Electrotechnical Commission (IEC).

CE Electromagnetic Compatibility

EN 55022:2010, Information Technology Equipment Radio Disturbance Characteristics – Limits and
Methods of Measurement

EN 55024:2010, Information Technology Equipment Immunity Characteristics – Limits and Methods
of Measurement

This is a Class A product. In a domestic environment, this product can cause radio interference, in
which case the user might be required to take adequate measures.

CE Safety

IEC 60950-1:2005, Information technology equipment – Safety, Part 1: General requirements

EN 60950-1:2006, Information technology equipment – Safety, Part 1: General requirements
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Compliance Markings
In August of 2005, the European Union (EU) implemented the EU Waste Electrical
and Electronic Equipment (WEEE) Directive 2002/96/EC and later the WEEE Recast
Directive 2012/19/EU. These directives require Producers of electronic and
electrical equipment (EEE) to manage and finance the collection, reuse, recycling
and to appropriately treat WEEE that the Producer places on the EU market after
August 13, 2005. The goal of this directive is to minimize the volume of electrical
and electronic waste disposal and to encourage re-use and recycling at the end
of life.
Xilinx has met its national obligations to the EU WEEE Directive by registering in
those countries to which Xilinx is an importer. Xilinx has also elected to join WEEE
Compliance Schemes in some countries to help manage customer returns at
end-of-life.
If you have purchased Xilinx-branded electrical or electronic products in the EU
and are intending to discard these products at the end of their useful life, please
do not dispose of them with your other household or municipal waste. Xilinx has
labeled its branded electronic products with the WEEE Symbol to alert our
customers that products bearing this label should not be disposed of in a landfill
or with municipal or household waste in the EU.

This product complies with Directive 2002/95/EC on the restriction of hazardous
substances (RoHS) in electrical and electronic equipment.

This product complies with CE Directives 2006/95/EC, Low Voltage Directive (LVD)
and 2004/108/EC, Electromagnetic Compatibility (EMC) Directive.
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Appendix B

Additional Resources and Legal
Notices

Xilinx Resources
For support resources such as Answers, Documentation, Downloads, and Forums, see Xilinx
Support.

Documentation Navigator and Design Hubs
Xilinx® Documentation Navigator (DocNav) provides access to Xilinx documents, videos, and
support resources, which you can filter and search to find information. To open DocNav:

• From the Vivado® IDE, select Help → Documentation and Tutorials.

• On Windows, select Start → All Programs → Xilinx Design Tools → DocNav.

• At the Linux command prompt, enter docnav.

Xilinx Design Hubs provide links to documentation organized by design tasks and other topics,
which you can use to learn key concepts and address frequently asked questions. To access the
Design Hubs:

• In DocNav, click the Design Hubs View tab.

• On the Xilinx website, see the Design Hubs page.

Note: For more information on DocNav, see the Documentation Navigator page on the Xilinx website.

References
These documents provide supplemental material useful with this guide:
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1. Alveo U50 Data Center Accelerator Card Installation Guide (UG1370)

Please Read: Important Legal Notices
The information disclosed to you hereunder (the "Materials") is provided solely for the selection
and use of Xilinx products. To the maximum extent permitted by applicable law: (1) Materials are
made available "AS IS" and with all faults, Xilinx hereby DISCLAIMS ALL WARRANTIES AND
CONDITIONS, EXPRESS, IMPLIED, OR STATUTORY, INCLUDING BUT NOT LIMITED TO
WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, OR FITNESS FOR ANY
PARTICULAR PURPOSE; and (2) Xilinx shall not be liable (whether in contract or tort, including
negligence, or under any other theory of liability) for any loss or damage of any kind or nature
related to, arising under, or in connection with, the Materials (including your use of the
Materials), including for any direct, indirect, special, incidental, or consequential loss or damage
(including loss of data, profits, goodwill, or any type of loss or damage suffered as a result of any
action brought by a third party) even if such damage or loss was reasonably foreseeable or Xilinx
had been advised of the possibility of the same. Xilinx assumes no obligation to correct any
errors contained in the Materials or to notify you of updates to the Materials or to product
specifications. You may not reproduce, modify, distribute, or publicly display the Materials
without prior written consent. Certain products are subject to the terms and conditions of
Xilinx's limited warranty, please refer to Xilinx's Terms of Sale which can be viewed at https://
www.xilinx.com/legal.htm#tos; IP cores may be subject to warranty and support terms contained
in a license issued to you by Xilinx. Xilinx products are not designed or intended to be fail-safe or
for use in any application requiring fail-safe performance; you assume sole risk and liability for
use of Xilinx products in such critical applications, please refer to Xilinx's Terms of Sale which can
be viewed at https://www.xilinx.com/legal.htm#tos.

AUTOMOTIVE APPLICATIONS DISCLAIMER

AUTOMOTIVE PRODUCTS (IDENTIFIED AS "XA" IN THE PART NUMBER) ARE NOT
WARRANTED FOR USE IN THE DEPLOYMENT OF AIRBAGS OR FOR USE IN APPLICATIONS
THAT AFFECT CONTROL OF A VEHICLE ("SAFETY APPLICATION") UNLESS THERE IS A
SAFETY CONCEPT OR REDUNDANCY FEATURE CONSISTENT WITH THE ISO 26262
AUTOMOTIVE SAFETY STANDARD ("SAFETY DESIGN"). CUSTOMER SHALL, PRIOR TO USING
OR DISTRIBUTING ANY SYSTEMS THAT INCORPORATE PRODUCTS, THOROUGHLY TEST
SUCH SYSTEMS FOR SAFETY PURPOSES. USE OF PRODUCTS IN A SAFETY APPLICATION
WITHOUT A SAFETY DESIGN IS FULLY AT THE RISK OF CUSTOMER, SUBJECT ONLY TO
APPLICABLE LAWS AND REGULATIONS GOVERNING LIMITATIONS ON PRODUCT
LIABILITY.
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