Overview

I Introduction

It is a CAN module designed for Raspberry Pi Pico,

enabling reliable long-range communication for Raspberry
Pi Pico with other devices.

CAN, SPI

I Features

e Standard Raspberry Pi Pico header, supports Raspberry Pi Pico series boards.

e Features CAN function, adopts SPI interface CAN controller MCP2515 with
transceiver SIT65HVD230DR.

e Comes with online development resources and manual (Raspberry Pi Pico C/C++
and MicroPython examples).

I Specifications

e Operating voltage: 3.3V~5V

e CAN controller: MCP2515

e Control interface: SPI

e CAN transceiver: SIT65HVD230DR
e Baudrate: 5K~1000Kbps

e Dimensions: 52 x 21Tmm

I Pinout Definition
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GP21 Interrupt output (default)
m INT2 Interrupt output (optional)
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Pico User Guide

I Hardware Connection

Please take care of the direction when you connect Pico, a USB port is printed to

indicate. You can also check the pin of Pico and the module when connecting.
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A EEEEEEEEEEEEE RS * Please correctly connect the Module and Raspberry Pi Pico as the picture shown.

I Demo Download

1. Directly download it on the Raspberry Pi: Open the Raspberry Pi and execute:

sudo apt-get install p7zip-full

cd ~

sudo wget https://files.waveshare.com/upload/8/8a/Pico-CAN-B-Code.7z
7z Pico_Pico-CAN-B-Code.7z -o0./Pico-CAN-B-Code.7z

cd ~/Pico-CAN-B-Code

2. Also, you can download the demo in the #Resource.

I How to Use the Demo

Python

e 1. Press and hold the BOOTSET button on the Pico board, connect the pico to
the USB interface of the computer through the Micro USB cable, and release the
button after the computer recognizes a removable hard disk (RPI-RP2).

e 2. Copy the pico_micropython xxxxx.uf2 file in the python directory to the
recognized removable disk (RPI-RP2).
o Download the official firmware .
e 3. Open Thonny IDE (Note: Please use the latest version of Thonny, otherwise
there is no Pico support package, the latest version in Windows is v3.3.3).

e 4 Click Tools -> Settings -> Interpreter, and select Pico and the corresponding
port as shown in the figure.

T& Thonny options bt

General | Interpreter | Editor | Theme & Font | Run & Debug iTernﬁnal | Shell | Assistant |

Which interpreter or device should Thonny use for running your code?

v

| MicroPython (Raspberry Pi Pica)

Details

Connect your device to the computer and select corresponding port below
{look for your device name, "USE Serial” or "UART").
If you can't find it, you may need to install proper USE driver first,

Port
USE SimEsE (COM4) [
| ]



https://www.raspberrypi.com/documentation/microcontrollers/#getting-started-with-micropython
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Install or update firmware -

‘ OK | ‘ Cancel
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e 5. File -> Open -> MCP2512.py file, click to run, as shown in the following figure:

Shell 3

MicroPython v1.13-298-g556ae7914 on 2021-81-21; Raspberry Pi Pico with RP2846
Type "help()" for more information.

»>»>» %Run -c $EDITOR CONTENT

This is a transceiver demo, connect to another CAN device (A-A B-B connection),
configure the frame ID 0x123, and then send 1-8 in turn.

Resource

I Document

e Schematic diagram &
e SN65HVD230#
e MCP2515&

I Demo

e Demo®

I Development Software

e Thonny Python IDE#
e 7Zimo221.7z&
e Win32Diskimager &

I Pico Quick Start

Download Firmware

e MicroPython Firmware Download

e C Blink Firmware Download [Expand]
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https://files.waveshare.com/upload/8/8a/Pico-CAN-B-Code.7z
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https://files.waveshare.com/upload/c/c6/Zimo221.7z
https://files.waveshare.com/upload/7/76/Win32DiskImager.zip

Video Tutorial

[Expand]

e Pico Tutorial | - Basic Introduction

e Pico Tutorial Il - GPIO

e Pico Tutorial lll - PWM

e Pico Tutorial IV - ADC

e Pico Tutorial V - UART

e Pico Tutorial VI - To be continued...

MicroPython Series

[Expand]
[Expand]
[Expand]
[Expand]
[Expand]

e [MicroPython]
e [MicroPython]
e [MicroPython]
e [MicroPython]
e [MicroPython]
e [MicroPython]
e [MicroPython]

C/C++ Series

machine.Pin Function &
machine.PWM Function &
machine.ADC Function#
machine.UART Function®
machine.l2C Function &
machine.SPI Function &

rp2.StateMachine#

e [C/C++] Windows Tutorial 1 - Environment Setting &

e [C/C++] Windows Tutorial 1 - Create New Projectd

Arduino IDE Series

Install Arduino IDE

1. Download the Arduino IDE installation package from Arduino website &.

HARDWARE

cLoup DOCUMENTATION =

COMMUNITY = BLOG ABOUT

Arduino Web Editor

Start coding online and save your sketches in the cloud, The most
up-to-date wersion of the IDE nctudes all ibraries and also
SUpPOrTs new Arduino boands.

CODE ONLINE

GETTING STARTED

Downloads

-----

DOWNLOAD OPTIONS
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w Arduino IDE 2.0.0

The new major release of the Arduing IDE Is faster and even more
powerful! In addition to a more modern editor and a more

responsive interface it features autocompletion, code navigation,
and even a live ﬂe'}U.E‘..E.Eﬁ macO5 10.14: Mojave” or newer, 54 bits

Linux Appimage &
Linux 7iF file 64 b

For more details, please refer to the Arduino IDE 2.0
decumentation.

Mightly bullds with the latest bugfixes are avallable through the
section below.

SOURCE CODE

The Arduino IDE 2.0 is open source and its source code is hosted on
GitHub,

2. Just click on "JUST DOWNLOAD".
Support the Arduino IDE

since the release 1.x release in March 2015, the Arduino IDE has
been downloaded 69,954,557 times — impressive! Help its
development with a donation.

$3 $5 $10 $25 $50 Other

JUST DOWNLOAD CONTRIBUTE & DOWNLOAD

Learn mare about donating to Arduino.

3. Click to install after downloading.
€8 Arduino Setup: License Agreement — *

P Please review the license agreement before installing Arduino. If you
2.2 accept all terms of the agreement, dick I Aagree.

GMU LESSER. GEMERAL PUBLIC LICEMSE LS
Version 3, 29 June 2007
Copyright (C) 2007 Free Software Foundation, Inc. <http://fsf.orgf>

Everyone is permitted to copy and distribute verbatim copies of this license
document, but chanaing it is not allowed.
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This wersion of the GML Lesser General Public License incorporates the terms
and conditions of version 3 of the GMU General Public License, supplemented

by the additional permissions listed below. -

Cancel | rullsoft Install Syskem v3.0 1 Agree I

4. Note: You will be prompted to install the driver during the installation
process, we can click Install.

Install Arduino-Pico Core on Arduino IDE

1. Open Arduino IDE, click the File on the left corner and choose "Preferences”.
File Edit Sketch Tools Help

MNew trl+MN
Open.. Ctrl+0
Sketchbook r
Examples r
Close Cirl+W
Save rl+5

Save As.. Ctrl+Shift+5
Preferences.. Ctl+iES
Advanced b
Quit Ctrl+Q
2. Add the following link in the additional development board manager URL,
then click OK.

https://github.com/earlephilhower/arduino-pico/releases/download/globa
1/package_rp2040_index.json

Praferences b4
Sattings Matwark
Sketchbook location
c '-\Jse:'s'xulnr-g'-Dul:umE ntstArduing BROWSE
[ Show files inside Skeiches
Editor font size 14
Interface scale Automatic 100 %
Thema Light (Arduino) w
Language English v  (Reload required)

Show verbose output during [ compile (] upload

Compiler wamnings Mone W

[ Verlfy coda after upload
M Auto save
[CIEdior Quick Suggestions

Additional boards manager URLs: hitps://dl espressif com/dl'package_esp32_index json

Note: If you already have the ESP8266 board URL, you can separate
the URLs with commas like this:


https://www.waveshare.com/wiki/File:RoArm-M1_Tutorial04.jpg
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https://dl.espressif.com/dl/package_esp32_index.json,https://github.co
m/earlephilhower/arduino-pico/releases/download/global/package_rp2040_i
ndex.json

3. Click on Tools -> Dev Board -> Dev Board Manager -> Search for pico, it
shows installed since my computer has already installed it.

Tools  Help
Archive Sketch
Manage Libraries... Ctrl+Shift=|
Serial Monitor Ctrl+Shift+M

Serial Plotter

WiFi101 / WiFiNINA Firmware Updater
Upload 551 Root Certificates

Board: "ESP32 Dev Module” L4 Boards Manager..  Ctrl+5Shift+B
ot ’ Arduino AVR Boards »
Get Board Info st "
CPU Frequency: "240MHz (WiFi/BT)" b

Core Debug Level: "None® 4

Flash Frequency: "80MHz" L4

Flash Mode: "QIC" 4

Flash Size: "4ME (32Mb)" »

Partition Scheme: "Default 4MB with spiffs (1.2MB APP/1.5MB SPIFFS)" L

PSRAM: "Disabled” »

Upload Speed: "921600" b

Burn Bootloader

BOARDS MANAGER

pico
g Type: Al b

Arduino Mbed OS5 RP2040

Boards by Arduino

Boards included in this package: Raspberry
Pi Pico

More info

404 ~ INSTALL

Raspberry Pi Pico/RP2040 by
Earle F. Philhower, 11

Boards included in this package: Raspberry
Pi Pico, Raspberry Pi Pico W, 0xCB Helios,
Adafruit Feather RP2040, Adafruit Feather...
More info

264 INSTALL
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Upload Demo At the First Time

1. Press and hold the BOOTSET button on the Pico board, connect the Pico to the
USB port of the computer via the Micro USB cable, and release the button
when the computer recognizes a removable hard drive (RPI-RP2).

2. Download the demo, open arduino\PWM\D1-LED path under the D1-LED.ino.

3. Click Tools -> Port, remember the existing COM, do not need to click this
COM (different computers show different COM, remember the existing COM
on your computer).

&3 UGVD1_BASE | Arduino IDE 2.0.2
File Edit Sketch Tool Help
Auto Format
Archive Sketch
LI Manage Libranies...

Serial Monitor

Senal Plotter
Board: "ESP32 Dev Module"
Port

Get Board Info

WiFi101 f WiRiNINA Firmware Updater

Upload 551 Root Certificates
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CPU Frequency

Core Debug Level

Hash Frequency
Flash Mode
Flash Size
PSRAM

Partition Scheme
Upload Speed

Burn Bootloader

4. Connect the driver board to the computer with a USB cable, then click Tools -
> Ports, select uf2 Board for the first connection, and after the upload is
complete, connecting again will result in an additional COM port.

&) UGVD1_BASE | Arduino IDE 2.0.2
File Edit Sketch Tools Help
Auto Format
Archive Sketch
ARG S Manage Libranies...

Serial Monitor

Sernial Plotter

Board: "ESP32 Dev Module®
Port: "COM10"
Get Board Info COM1

v COMI0
WiFi101 f WiRFiNINA Firmware Updater

Upload 551 Root Certificates

CPU Frequency

Core Debug Level

Hash Frequency
Flash Mode
Hash Size
PSRAM

Partition Scheme
Upload Speed

Burn Bootloader

5. Click Tool -> Dev Board -> Raspberry Pi Pico/RP2040 -> Raspberry Pi Pico.

Tools Help
Archive Sketch
Manage Libraries.. Ctrl+Shift+l
Serial Monitor Ctrl+Shift+M
Serial Plotter

WiFi107 /£ WiFININA Firmware Updater

Upload 551 Root Certificates

Rnard: "FSP32 New Madula" b Rnards Manansr. Ctrl+Shift=R
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e e e L B .

Port b
Arduino AVR Boards

Get Board Info
esp32

CPU Frequency: "240MHz (WiFi/BT)" Raspberry Pi Pico/RP2040

Core Debug Level: "Mone®

Flash Frequency: "80MHz"

Flash Mode: "QIO"

Flash Size: "4MB (32Mb)"

Partition Scheme: "Default 4MEB with spiffs (1.2MB APP/1.5MB SPIFFS)"
PSRAM: "Disabled”

Upload Speed: "921600"

* v w w v w w ¥

Burn Bootloader

6. After setting, click the right arrow to upload.
e} sketch_augl6a | Arduino IDE 2.1.0

File Edit Sketch Tools Help

¥ Raspberry Pi Pico

o If you encounter problems during the period, you need to reinstall or
replace the Arduino IDE version, uninstall the Arduino IDE needs to be
uninstalled cleanly, after uninstalling the software you need to manually
delete all the contents of the folder C:\Users\
[name]\AppData\Local\Arduino15 (you need to show the hidden files in
order to see it) and then reinstall.

Pico-W Series Tutorial (To be continued...)

Open Source Demo

MicroPython Demo (GitHub) &

MicroPython Firmware/Blink Demo (C) &

Official Raspberry Pi C/C++ Demo®

Official Raspberry Pi MicroPython Demo &
Arduino Official C/C++ Demo®

I Open-source Demo

e MircoPython video demo (GitHub) &

e MicroPython firmware/Blink demo(C) &

e Raspberry Pi's official C/C++ sample demo (GitHub)#

e Raspberry Pi's official micro python sample demo (GitHub) &

e Raspberry Pi Pico Demo.zip &

Support
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Submit Now
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