
June 2014 DocID026533 Rev 1 1/19

UM1790
User manual

Getting started with STM32L053 discovery kit 
 software development tools

Introduction

This document describes the software environment recommendations required to build an 
application using the STM32L053 discovery kit (32L0538DISCOVERY).

The document provides guidelines to user how to build and run a sample example and how 
to create and build his own application. It has the following structure: 

The first chapter presents software and hardware requirements (some toolchains supporting 
the STM32 families, ST-LINK/V2-1 installation and firmware package presentation). 

The second chapter provides step by step guideline on how to execute and debug an 
application example using some toolchains:

– IAR Embedded Workbench® for ARM® (EWARM) by IAR systems® 

– Microcontroller development kit for ARM® (MDK-ARM) by Keil® 

– TrueSTUDIO® by Atollic.

Although this user manual does not cover all the topics relevant to software development 
environment, it demonstrates the first basic steps necessary to get started with the 
compilers/debuggers and includes references for complementary information.

www.st.com
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1 System requirements

Before running your application, you should:

1. Install your preferred Integrated Development Environment (IDE)

2. ST-LINK/V2-1 driver will be installed automatically. In case of problem, you can 
proceed with manual installation of the driver from toolchains install directory (further 
details are available in Section 2).

3. Download the STM32L0538 discovery kit firmware from www.st.com/stm32l0-
discovery.

4. Establish the connection with the STM32L0538 discovery board as following:

Figure 1. Hardware environment

The above steps will be details in the coming sections.

To run and develop any firmware applications on your STM32L053 discovery board, the 
minimum requirements are as follows:

– Windows PC (XP, Vista, 7, 8)

– ‘USB type A to Mini-B' cable, used to power the board (through USB connector 
CN1) from host PC and connect to the embedded ST-LINK/V2-1 for debugging 
and programming.

http://www.st.com/stm32f3-discovery
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2 IDEs supporting STM32 Families

STM32 families of 32-bit ARM® Cortex®-M core-based microcontrollers are supported by a 
complete range of software tools. It encompasses traditional integrated development 
environments IDEs with C/C++ compilers and debuggers from major 3rd-parties (free 
versions up to 64KB of code, depending on partner), completed with innovative tools from 
STMicroelectronics.

The following table regroups general information about most used integrated development 
environments as well as the version supporting officially STM32L053 product.

Table 1. Useful links 

Toolchain Company Compiler Version Download link(1)

1. Registration before download is required.

EWARM
IAR 

Systems® IAR C/C++
7.10 

and 
later

www.iar.com: 

– 30-day evaluation edition

– KickStart edition(16Ko Limitation for Cortex® 
M0)

MDK-ARM(2)

2. Device database is updated separately from MDK-ARM release.

Keil® ARMCC
5.01 
and 
later

www.keil.com: 

MDK-Lite (32Ko Code size limitation)

TrueSTUDIO® Atollic GNUC
5.0.0 
and 
later

www.atollic.com(1)

– 32Ko Limitation (8Ko on Cortex®-M0 and 
Cortex®-M1)

– 30 day Professional version (Trial)

http://www.atollic.com/index.php/request-eval-license
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3 ST-LINK/V2-1 installation

STM32L053 discovery board includes an ST-LINK/V2-1 embedded debug tool interface. 
The interface needs an ST-LINK/V2-1 dedicated USB driver to be installed. This driver is 
available at www.st.com searching for ST-LINK V2-1 and is supported within software 
toolchains:

• IAR Embedded Workbench® for ARM® (EWARM)  

The toolchain is installed by default in the C:\Program Files\IAR Systems\Embedded 
Workbench x.x directory on the PC’s local hard disk.

After installing EWARM, install the ST-LINK/V2-1 driver by running the ST-
LINK_V2_USB.exe from [IAR_INSTALL_DIRECTORY]\Embedded Workbench 
x.x\arm\drivers\ST-LINK \ST-LINK_V2_USBdriver.exe

• Keil® Microcontroller Development Kit (MDK-ARM) toolchain 

The toolchain is installed by default in the C:\Keil directory on the PC’s local hard disk; 
the installer creates a start menu µVision4 shortcut.

When connecting the ST-LINK/V2-1 tool, the PC detects new hardware and asks to 
install the ST-LINK_V2_USB driver. The “found new hardware wizard” appears and 
guides you through the steps needed to install the driver from the recommended 
location.

• Atollic TrueSTUDIO® STM32 

The toolchain is installed by default in the C:\Program Files\Atollic directory on the PC’s 
local hard disk.

The ST-LINK_V2_USB.exe is installed automatically when installing the software 
toolchain.

Complementary information on the firmware package content and the STM32L0538 
discovery kit requirements are available on the Getting started with STM32Firmware.

Note: The embedded ST-LINK/V2-1 supports only SWD interface for STM32 devices. 

http://www.st.com
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4 Firmware package

The STM32L053 discovery kit firmware applications, demonstration and IPs examples are 
provided in one single package and supplied in one single zip file. The extraction of the zip 
file generates one folder, STM32L053-Discovery_FW_VX.Y.Z, which contains the following 
subfolders:

Figure 2. Package contents

Application examples: Including set of applications with pre-configured projects. 

Demonstrations: Including set of demonstrations with pre-configured projects.

Peripheral examples: Including set of examples with pre-configured projects for each 
peripheral. 

Template project: pre-configured project with empty main function to be customized. This 
is helpful to get start creating your own application based on the peripherals drivers.
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5 Executing and debugging firmware using software 
toolchains

5.1 EWARM toolchain

The following is the procedure for compiling/linking and executing an existing EWARM 
project.

Steps below can be applied to an already existing example, demonstration or template 
project included in STM32L053 discovery package that is available at www.st.com web site.

First of all, you need to go through firmware/readme.txt file which contains the firmware 
description and hardware/software requirements.

1. Open the IAR Embedded Workbench® for ARM (EWARM). Figure 3shows the basic names of the windows referred to this document.
Figure 3. IAR embedded workbench IDE

2. In the File menu, select Open and click Workspace to display the Open Workspace 
dialog box. Browse to select either an example or demonstration or template 
workspace file and click Open to launch it in the Project window.

3. In the Project menu, select Rebuild All to compile your project

4. If your project is successfully compiled, the following window in Figure 4 is displayed

Figure 4. EWARM project successfully compiled

http://www.st.com
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If you needs to change his project settings (Include and preprocessor defines), he has just 
to go through project options: 

• For Include directories’

Project>Options…>C/C++ compiler> 

• For pre-processor defines

Project>Options…C/C++ compiler>pre-processor>     

5. In the IAR Embedded Workbench IDE, from the Project menu, select Download and 
Debug or, alternatively, click the Download and Debug button the in toolbar, to 
program the Flash memory and begin debugging.

Figure 5. Download and debug button

6. The debugger in the IAR embedded workbench can be used to debug source code at 
C and assembly levels, set breakpoints, monitor individual variables and watch events 
during the code execution.

Figure 6. IAR Embedded Workbench® debugger screen
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To run your application, from the Debug menu, select Go. Alternatively, click the Go button 
in the toolbar to run your application.

Figure 7. Go button

5.2 MDK-ARM toolchain

1. Open Keil MDK-ARM Microcontroller development kit, Figure 8 shows the basic names 
of the “Keil uVision5” windows referred to in this document.

Figure 8. uVision5 IDE

2. In the Project menu, select Open Project... Browse to select either an example or 
demonstration or template project file and click Open to launch it in the Project window. 

3. In the Project menu, select Rebuild All target files to compile your project 

4. If your project is successfully compiled, the following window in Figure 9 is displayed
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Figure 9. MDK-ARM project successfully compiled

If you need to change your project settings (Include and preprocessor defines), you need 
just to go through project options: 

• For include directories’

Project>Options for Target > C/C++ > Include Paths

• For pre-processor defines

Project>Options for Target > C/C++ > Preprocessor symbols > Define 

5. In the MDK-ARM IDE, from the Debug menu, select Start/Stop Debug Session or, 
alternatively, click the Start/Stop Debug Session button the in toolbar, to program the 
Flash memory and begin debugging.

Figure 10. Start/Stop Debug Session button
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6. The debugger in the MDK-ARM can be used to debug source code at C and assembly 
levels, set breakpoints, monitor individual variables and watch events during the code 
execution.

Figure 11. MDK-ARM debugger screen

To run your application, from the Debug menu, select Run. Alternatively, click the Run 
button in the toolbar to run your application

Figure 12. Run button



Executing and debugging firmware using software toolchains UM1790

14/19 DocID026533 Rev 1

5.3 TrueSTUDIO® toolchain

1. Open Atollic TrueSTUDIO® for ARM product. The program launches and asks for the 
workspace location.

Figure 13. TrueSTUDIO® workspace launcher dialog box

2. Browse to select a TrueSTUDIO workspace of either an example or demonstration or 
template workspace file and click OK to load it.

3. To load an existing project in the selected workspace, select Import from the File menu 
to display the Import dialog box.

4. In the Import window, open General, select existing projects into workspace and click 
next.

Figure 14. Atollic TrueSTUDIO® inport source select dialog box
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5. Click Select root directory, browse to the TrueSTUDIO workspace folder and select
Figure 15. Atollic TrueSTUDIO® import projects dialog box

6. In the Projects panel, select the project and click Finish.

7.  In the Project Explorer, select the project, open the Project menu, and click build 
Project.

8. If your project is successfully compiled, the following messages will be displayed on the 
Console window.

Figure 16. TrueSTUDIO® project successfully compiled

If you needs to change the project settings (Include directories and preprocessor defines), 
you need just to go through Project>Properties, select C/C++ Build>Settings from the left 
panel: 

• For Include directories’

C Compiler>Directories>Include path

• For pre-processor defines

C Compiler>Symbols> Defined symbols
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9. To debug and run the application, select the project In the Project Explorer and 
press F11 to start a debug session. 
In the Project Explorer, select the project and press F11 to start a debug session (see 
Figure 17).

Figure 17. TrueSTUDIO® project successfully compiled

The debugger in the Atollic TrueSTUDIO can be used to debug source code at C and 
assembly levels, set breakpoints, monitor individual variables and watch events during the 
code execution.

To run your application, from the run menu, select Resume, or alternatively click the resume 
button in the toolbar.
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6 SW toolchains helpful references and links

The following table regroups useful references about integrated development environments 
described in this document:

Table 2. References and links

Toolchain Download link

EWARM www.iar.com

MDK-ARM www.keil.com

TrueSTUDIO® www.atollic.com

http://www.keil.com/demo/eval/arm.htm
http://www.keil.com/arm/mdk.asp
http://www.atollic.com/index.php/request-eval-license
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7 Revision history

          

Table 3. Document revision history

Date Revision Changes

26-June-2014 1 initial release
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